// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([0-2]+\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])\.([0-2]?\d[0-5]?|[1]\d?\d+|[1-9][0-9])$").unwrap();
let string = "212.88.197.8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}