// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z,.'-]{2,} +[A-Za-z,.'-]{2,}$").unwrap();
let string = "firstname
Lastname
F lastname
firstname l
Firstname Lastname
f-name lastname
someguy en'try
Patrick O'Brian
web dev@
'f names
Mr. Bean
.hidden file";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}