$re = '/^([1-9]?\d(\.\d{1,2})?|100(\.0{1,2})?)$/m';
$str = '1000
101
100.01
100.00
100.0
100
12.30
12.34
12.3
12
012
1.20
1.2
1
01.2
0.10
0.1
.1
01
00
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);