$re = '/[^][(){}]/';
$str = '(9*[3*{[(3+3)/5]*7}])';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;