$re = '/^(?i)a(?-i).*$/m';
$str = 'a
ab
Ab
bb
Bb
b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);