#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d+\.){3}\d+$"
Local $sString = "4:16:09PM - xx yy DOS activity from 10.0.0.45" & @CRLF & _
"9:43:44PM - xx yy 1A disconnected from server" & @CRLF & _
"2:40:28AM - xx yy 1A connected" & @CRLF & _
"1:21:52AM - xx yy DOS activity from 192.168.123.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")