import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.+?class=[\"'].*?hero-class.*?[\"'].*?src=[\"'](.+?)[\"'].*?>";
final String string = "// it should match but it didn't\n"
+ "<img src=\"image.jpg\" class=\"hero-class\">\n\n"
+ "// it shouldn't match class 'nohero-class-dont-match'\n"
+ "<img class=\"nohero-class-dont-match\" src=\"image.jpg\">\n\n"
+ "// it shouldn't match custom tag 'imgs-tag'\n"
+ "<imgs-tag class=\"hero-class\" src=\"image.jpg\">\n\n"
+ "// it shouldn't match two tags and text between them\n"
+ "<img src=\"foo.jpg\" class=\"hero-class\"> any text <img src=\"image.jpg\">\n\n"
+ "// it should match whole src attribute, not just part\n"
+ "<img class=\"hero-class\" src=\"mcdonald's.jpg\">\n\n"
+ "// it shouldn't match custom attribute 'data-src'\n"
+ "<img class=\"hero-class\" data-src=\"custom info\" src=\"image.jpg\">\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}