# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.+?class=[\"'].*?hero-class.*?[\"'].*?src=[\"'](.+?)[\"'].*?>"
test_str = ("// it should match but it didn't\n"
"<img src=\"image.jpg\" class=\"hero-class\">\n\n"
"// it shouldn't match class 'nohero-class-dont-match'\n"
"<img class=\"nohero-class-dont-match\" src=\"image.jpg\">\n\n"
"// it shouldn't match custom tag 'imgs-tag'\n"
"<imgs-tag class=\"hero-class\" src=\"image.jpg\">\n\n"
"// it shouldn't match two tags and text between them\n"
"<img src=\"foo.jpg\" class=\"hero-class\"> any text <img src=\"image.jpg\">\n\n"
"// it should match whole src attribute, not just part\n"
"<img class=\"hero-class\" src=\"mcdonald's.jpg\">\n\n"
"// it shouldn't match custom attribute 'data-src'\n"
"<img class=\"hero-class\" data-src=\"custom info\" src=\"image.jpg\">\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.