import Foundation
let pattern = #"<img.+?class=["'].*?hero-class.*?["'].*?src=["'](.+?)["'].*?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// it should match but it didn't
<img src="image.jpg" class="hero-class">
// it shouldn't match class 'nohero-class-dont-match'
<img class="nohero-class-dont-match" src="image.jpg">
// it shouldn't match custom tag 'imgs-tag'
<imgs-tag class="hero-class" src="image.jpg">
// it shouldn't match two tags and text between them
<img src="foo.jpg" class="hero-class"> any text <img src="image.jpg">
// it should match whole src attribute, not just part
<img class="hero-class" src="mcdonald's.jpg">
// it shouldn't match custom attribute 'data-src'
<img class="hero-class" data-src="custom info" src="image.jpg">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)