use strict;
my $str = 'Customers are advised to follow <A HREF=\'https://support.microsoft.com/en-ph/help/4343902/security-update-for-adobe-flash-player\' TARGET=\'_blank\'>KB4343902</A> for instructions pertaining to the remediation of these vulnerabilities.<P> <P>Patch:<br/> Following are links for downloading patches to fix the vulnerabilities: <P> <A HREF=\'https://portal.msrc.microsoft.com/en-us/security-guidance/advisory/ADV180020\' TARGET=\'_blank\'>ADV180020</A>';
my $regex = qr/((?=<[^>]>)[^;]+;[^;]+;|<[^>]>|<\/[^>]+>|<[^'"]+['"]|['"][^<]+<[^>]+>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";