using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$";
string input = @"test@test.com;sample@google.com;dsdsd@dsd.sd
te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com
test@test.com;sample@google.com dsdsd@dsd.sd
test@test.com
test@test.com;
test@test.com; test@Tes.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}