import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*;$)^([-\\w]+?@\\w+\\.\\w+(?:\\s*;\\s*)?)+$";
final String string = "test@test.com;sample@google.com;dsdsd@dsd.sd\n"
+ "te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com\n"
+ "test@test.com;sample@google.com dsdsd@dsd.sd\n"
+ "test@test.com\n"
+ "test@test.com;\n\n"
+ "test@test.com; test@Tes.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}