#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Filter:(?:\w+=[^;]*;)*$"
Local $sString = "Filter:Class=RBSG_Root_Base;" & @CRLF & _
"Filter:Class=Logfile_Base;" & @CRLF & _
"Filter:Class=Logfile_Sendmail;" & @CRLF & _
"Filter:Class=Daemon_Notice;" & @CRLF & _
"Filter:Class=Logfile_Syslogd;msg=re:'syslogd: restart';" & @CRLF & _
"Filter:Class=Logfile_Cron;msg=re:'CMD';" & @CRLF & _
"Filter:Class=Logfile_Cron;msg=re:'STARTUP';" & @CRLF & _
"Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:'support';" & @CRLF & _
"Filter:ClassAppLog;sub_sourceMTRMonmsg=re:'su;dnsdjs;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")