using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Filter:(?:\w+=[^;]*;)*$";
string input = @"Filter:Class=RBSG_Root_Base;
Filter:Class=Logfile_Base;
Filter:Class=Logfile_Sendmail;
Filter:Class=Daemon_Notice;
Filter:Class=Logfile_Syslogd;msg=re:'syslogd: restart';
Filter:Class=Logfile_Cron;msg=re:'CMD';
Filter:Class=Logfile_Cron;msg=re:'STARTUP';
Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:'support';
Filter:ClassAppLog;sub_sourceMTRMonmsg=re:'su;dnsdjs;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}