// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Filter:(?:\w+=[^;]*;)*$").unwrap();
let string = "Filter:Class=RBSG_Root_Base;
Filter:Class=Logfile_Base;
Filter:Class=Logfile_Sendmail;
Filter:Class=Daemon_Notice;
Filter:Class=Logfile_Syslogd;msg=re:'syslogd: restart';
Filter:Class=Logfile_Cron;msg=re:'CMD';
Filter:Class=Logfile_Cron;msg=re:'STARTUP';
Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:'support';
Filter:ClassAppLog;sub_sourceMTRMonmsg=re:'su;dnsdjs;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}