package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$`)
var str = `3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}