$re = '/^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$/m';
$str = '3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);