// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$").unwrap();
let string = "3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}