const regex = /udp\s+.\d+\s+\d+\s+(?!127.0.0.1)\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}:514\s+0\.0\.0\.0:\*\s+(\d+)\/syslog-ng/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('udp\\s+.\\d+\\s+\\d+\\s+(?!127.0.0.1)\\d{1,3}.\\d{1,3}.\\d{1,3}.\\d{1,3}:514\\s+0\\.0\\.0\\.0:\\*\\s+(\\d+)\\\/syslog-ng', 'g')
const str = `udp 0 0 0.0.0.0:514 0.0.0.0:* 2103/syslog-ng
udp 0 0 127.0.0.1:514 0.0.0.0:* 2103/syslog-ng
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}