use strict;
my $str = 'udp 0 0 0.0.0.0:514 0.0.0.0:* 2103/syslog-ng
udp 0 0 127.0.0.1:514 0.0.0.0:* 2103/syslog-ng
';
my $regex = qr/udp\s+.\d+\s+\d+\s+(?!127.0.0.1)\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}:514\s+0\.0\.0\.0:\*\s+(\d+)\/syslog-ng/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}