Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\d+(\.\d+)?([Ee]\D+)?
/
gm
Input 1
1
New
This is just a test where we can have multiple email addresses which can be gil@home.com g.echeverria@tec.mx gil2@one.long.domain.org Or something more elaborate one1.two2-three3@is.this-site.real.net brave_world@survive.com.it And just like that there can me more formats for emails But how can we extract those 34.76e4 875 34.43.34.676