import re
regex = re.compile(r"\d+(\.\d+)?([Ee]\D+)?", flags=re.MULTILINE)
test_str = ("This is just a test\n"
"where we can have multiple email addresses\n"
"which can be gil@home.com\n"
"g.echeverria@tec.mx\n"
"gil2@one.long.domain.org\n"
"Or something more elaborate\n"
"one1.two2-three3@is.this-site.real.net\n"
"brave_world@survive.com.it\n"
"And just like that there can me more formats for emails\n"
"But how can we extract those\n"
"34.76e4\n"
"875\n"
"34.43.34.676")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")