$re = '/(?<base>.+?)(\((?<idx>\d+)\)?)?(?<ext>(\.[\w\.]+))/m';
$str = 'somefile.docx
somefile
somefile (6)
somefile (1).docx
somefile (2)(1).docx
somefile (4).htm.tmpl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);