# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)/\1=\2/gm;t' <<< "air.BattleofZombies 0.0008 0.0006 -0.0027
air.BattleofZombies 0.0008
air.BattleofZombies 0.0008 7877
air.BattleofZombies -0.0008 656 -984.98"