use strict;
my $str = 'air.BattleofZombies 0.0008 0.0006 -0.0027
air.BattleofZombies 0.0008
air.BattleofZombies 0.0008 7877
air.BattleofZombies -0.0008 656 -984.98';
my $regex = qr/(\S+)\s+(-?\d+(?:\.\d+)?(?:\s+-?\d+(?:\.\d+)?)*)/mp;
my $subst = '\\1=\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";