using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^WM\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})$";
string input = @"WM/1F0.E89D/5.D00F.BA7C";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}