import Foundation
let pattern = #"^WM\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"WM/1F0.E89D/5.D00F.BA7C"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}