const regex = /session\(\{\s*secret\:\s*("|')\w*("|')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('session\\(\\{\\s*secret\\:\\s*("|\')\\w*("|\')\\s*,\\s*resave\\s*\\:\\s*false\\,\\s*saveUninitialized\\:\\s*false\\,?\\s*\\}\\)', 'gm')
const str = `session({
secret: "asdfadf",
resave: false,
saveUninitialized: false,
})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}