re = /session\(\{\s*secret\:\s*("|')\w*("|')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)/m
str = 'session({
secret: "asdfadf",
resave: false,
saveUninitialized: false,
})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end