package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\\([^\\]+)\\`)
var str = `G:\DATA1\DATA2\DATA3\DATA4\my target\file.xxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}