#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s]+(?=\s+\w{7}\s)"
Local $sString = "remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)" & @CRLF & _
"remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")