Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[^\s]+(?=\s+\w{7}\s)
/
gm
Test String
New
remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges) remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace