re = /^[^\s]+(?=\s+\w{7}\s)/m
str = 'remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)
remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end