re = /(?:^listings\/view\/)(?:.*)-(\d+)(?!.*\d)(?:\.html)$/m
str = 'listings/view/5330-carmel-crest-lane-charlotte-nc-homes-for-sale-3530458.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end