const regex = /^\(?([+]31)-?6(\s?|-)([0-9]\s{0,3}){8}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(?([+]31)-?6(\\s?|-)([0-9]\\s{0,3}){8}$', '')
const str = `+31612345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}