package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(GET|POST)\s(http|https)://(www.)?(\w+(\.|-)?)+/(\w+(\.)?)+/((\w|-)+(\.)?)+/(\w+(/)?){4}`)
var str = `GET http://dpservers-pre.alipay.com/odps/service.odps.aliyun-inc.com/api/projects/alipaytech_dev/instances/AQE_409d5e440042b0fa3ff8eb54ddb9dad2?instanceprogress=SQL&taskname=SQL&curr_project=alipaytech_dev`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}