re = /\/\*([^*]|\*+[^*\/])*\*+\//m
str = '/* comment */ hello world /***** ooo *****/ asdfg /*/***
newline
***/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end