using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Профессиональная ГИС \""Панорама\"" \(версия 12(\.\d+){2,}, для платформы \""x(32|64)\""\)";
string input = @"Профессиональная ГИС ""Панорама"" (версия 12.4.0, для платформы ""x64"")
Профессиональная ГИС ""Панорама"" (версия 12.4.0, для платформы ""x32"")";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}