import Foundation
let pattern = #"^.+-REFERENCE-+([A-Za-z0-9.?\/-]*)(.*).html$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://www.comptoirdelencens.fr/FR/produit_detail-famille-cristaux_huiles-gamme-cristaux_huiles_essentielles-REFERENCE-CR22.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}