re = /(?<=(<)(?i)(script))([^\/].+?)(>)/
str = '<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>
(?<=(<)([sS][cC][rR][iI][pP][tT]))([^\\/].+?)(>)
(?<=(<)(?i)(script))([^\\/].+?)(>)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end