$re = '/(?<=\[)[^\[\]]+(?=\])/';
$str = 'this is [[test]] line i [want] text [inside] square [brackets]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);