using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$";
string input = @"Dear user 1 2222 thanks
Dear user12345 64789 thanks
Dear user12345 6479 thanks
Dear user12345 6489 thanks
Dear user 12345 64789 thanks
Dear user 123 5 6789 thanks
Dear user 123 5 68 4 thanks
Dear user 1 thanks
Dear user thanks
Dear user 1 2 thanks
Dear user 43265 thanks
Dear user 43265 thanks
Dear user thanks
Dear user thanks";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}