use strict;
my $str = 'Dear user 1 2222 thanks
Dear user12345 64789 thanks
Dear user12345 6479 thanks
Dear user12345 6489 thanks
Dear user 12345 64789 thanks
Dear user 123 5 6789 thanks
Dear user 123 5 68 4 thanks
Dear user 1 thanks
Dear user thanks
Dear user 1 2 thanks
Dear user 43265 thanks
Dear user 43265 thanks
Dear user thanks
Dear user thanks';
my $regex = qr/^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}