import Foundation
let pattern = #"^Dear\s*user(\s*\d)?(?(1)(.{1,5})(?=(\s{1,}))(?<!(\s{2}))(.{1,5}) thanks|\s*thanks)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Dear user 1 2222 thanks
Dear user12345 64789 thanks
Dear user12345 6479 thanks
Dear user12345 6489 thanks
Dear user 12345 64789 thanks
Dear user 123 5 6789 thanks
Dear user 123 5 68 4 thanks
Dear user 1 thanks
Dear user thanks
Dear user 1 2 thanks
Dear user 43265 thanks
Dear user 43265 thanks
Dear user thanks
Dear user thanks
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)