const regex = /(\d+),\1/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+),\\1', 'gi')
const str = `007,007,001,002,002,003,002,004,007,007`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}