# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})//;t' <<< "ericabraham.ea@gmail.com"