use strict;
my $str = '1.3SAHIN/FATMAMRS/MUSTAFAMR/SEMIHMSTR 4.I/1SAHIN/MUSABMSTR
2ZSTKOS 13SEP UNBFML
1 TK1616 W WE 25NOV FRASAW HK3 X 1745 2145 Y M01.1E
2 TK7230 Y WE 25NOV SAWTZX HK3 2245 0025*Y M01.2E
ANADOLUJET IS A TRADEMARK OF TURKISH AIRLINES
3 TK2839 Y SA 12DEC TZXIST HK3 X 0645 0840 Y M02.1E
4 TK1591 S SA 12DEC ISTFRA HK3 1140 1355 Y M02.2E
FONE-2ZS00-T REISEBURO SAHIN 06042/951616';
my $regex = qr/\s[0-9]\s([A-Z]{2,3})([0-9\s]{4})\s([A-Z])\s\s([A-Z]{1,2})\s([0-9]{1,2})(JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC)\s\s([A-Z]{3})([A-Z]{3})\s([A-Z0-9]{3})\s(X|\s)\s([0-9]{2})([0-9]{2})\s([0-9]{2})([0-9]{2})(\s|\*)([A-Z]*)\s(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}