import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\/(?=packages|videos).*?\\/(\\d+)";
final String string = "<iframe src=\"http://embed.app.com/packages/495\" width=\"850\" height=\"480\" frameborder=\"0\" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe>\n"
+ "<iframe src=\"https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0\" width=\"960\" height=\"540\" class=\"responsive-embed\"></iframe>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}