const regex = /^.*?\/(?=packages|videos).*?\/(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\\/(?=packages|videos).*?\\\/(\\d+)', 'gm')
const str = `<iframe src="http://embed.app.com/packages/495" width="850" height="480" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe>
<iframe src="https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0" width="960" height="540" class="responsive-embed"></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}