$re = '/^.*?\/(?=packages|videos).*?\/(\d+)/m';
$str = '<iframe src="http://embed.app.com/packages/495" width="850" height="480" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe>
<iframe src="https://embed.app.com/videos/10332?hide_text=1&buy_btn=0&autoplay=0" width="960" height="540" class="responsive-embed"></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);